shwq.net
当前位置:首页 >> 为什么装了ApAChE还要装PHP呢 >>

为什么装了ApAChE还要装PHP呢

不是必须 , 但是我们一般都用APACHE来做PHP的服务器,为了保持环境一致,建议使用apache. 其他也可以用IIS , 或者PHP5.4以上版本自带了一个测试服务器.

不是必须,不过现在大部分的PHP都是在Apache服务器下运行,集成包也都是集成Apache+PHP+MySQL软件,像wamp,xamp,phpstudy;你可以下一个安装,如果是在linux,还可以安装Nginx

无法解析php网页的情况主要有以下几种: apache文件缺失以下内容 AddType application/x-httpd-php .php AddType application/x-httpd-php .php .phtml .php3 AddType application/x-httpd-php-source .phps 缺失index.php文件 DirectoryIndex i...

安装集成包,集成包里配置好了PHP,MySQL,Apache, 常见的集成包有 xamp,wamp,phpstudy,使用起来快捷又方便

php与apache一般通过module进行交互的,你唯一要做的是apache对php的配置做完,什么module,addtype之类的,然后就是设置环境变量。校验环境变量是否设置正确,只用在命令行输入php -v,有php版本信息出来证明你装正确了,提示你php不是系统命令...

不用 phpstudy把apache\php\mysql等常用的php开发需要的工具都包括在里面了

你确定你已经能安装phpMyAdmin了?如果你已经能安装了那么说明你已经有了web服务器同时能解析PHP脚本了那么,只能说明你已经安装了PHP+apache+mysql或者是PHP+IIs+mysql了。

只有由其他web服务器软件就可以,如IIS、Nginx 建议安装护卫神.主机大师,一键安装PHP环境。

编译php的时候,加入--with-apxs2=/usr/local/apache/bin/apxs 此处路径修改成你的apache的安装路径下/bin/apxs 意思就是将php编译成apache的一个模块

网站首页 | 网站地图
All rights reserved Powered by www.shwq.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com